summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-09 11:25:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-09 11:26:42 +0200
commit3a341e822c8c73af9d8620858c66340119c5b800 (patch)
tree4dc47b85a339ce12eccd8e0159c961535f5c2a4d /gnu
parentc10a27a2683afee30c4f0ea22c04ea3212dd3853 (diff)
downloadguix-patches-3a341e822c8c73af9d8620858c66340119c5b800.tar
guix-patches-3a341e822c8c73af9d8620858c66340119c5b800.tar.gz
gnu: Add r-soupx.
* gnu/packages/cran.scm (r-soupx): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b09d46678a..6ef2066429 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15335,3 +15335,33 @@ an approach to manipulate these two virtual data frames using the API defined
in the @code{dplyr} package, and it also provides tidy interfaces to a lot of
common graph algorithms.")
(license license:expat)))
+
+(define-public r-soupx
+ (let ((commit "a3354be76fb52fd795be6ddf163cf056c05c6cb8")
+ (revision "1"))
+ (package
+ (name "r-soupx")
+ (version (git-version "0.3.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/constantAmateur/SoupX")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zmlyzrl0fz6l79gn2wswid670p88mm3y292is89sa5p3h7frr99"))))
+ (properties `((upstream-name . "SoupX")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-matrix" ,r-matrix)
+ ("r-seurat" ,r-seurat)))
+ (home-page "https://github.com/constantAmateur/SoupX")
+ (synopsis "Single cell mRNA Soup eXterminator")
+ (description
+ "This package provides a package for quantifying, profiling and
+removing cell free mRNA contamination (the \"soup\") from droplet based single
+cell RNA-seq experiments.")
+ (license license:gpl2))))