summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:03:36 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:17 +0300
commit37cb391ea6393e908bb36ddf6c9c5121a7457fc0 (patch)
tree34e1dac7b21233578a1ec6bc64b691095eaf1cb6 /gnu
parent0b7442491efb1a1cfe3b7e736bf94aec7fef9768 (diff)
downloadguix-patches-37cb391ea6393e908bb36ddf6c9c5121a7457fc0.tar
guix-patches-37cb391ea6393e908bb36ddf6c9c5121a7457fc0.tar.gz
gnu: Add go-github-com-mitchellh-reflectwalk.
* gnu/packages/golang.scm (go-github-com-mitchellh-reflectwalk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9c984c83ea..c87bc26562 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2754,6 +2754,29 @@ cross-compilation.")
(description "Go library for decoding generic map values")
(license license:expat)))
+(define-public go-github-com-mitchellh-reflectwalk
+ (package
+ (name "go-github-com-mitchellh-reflectwalk")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/reflectwalk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pa6a3nhzwv5s5yqcmsmsfhdp5ggxsg2wa86f3akawxrhrkjarnx"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/mitchellh/reflectwalk"))
+ (home-page "https://github.com/mitchellh/reflectwalk/")
+ (synopsis "Walk a value in Go using reflection")
+ (description "reflectwalk is a Go library for \"walking\" a value in Go
+using reflection, in the same way a directory tree can be \"walked\" on the
+filesystem. Walking a complex structure can allow you to do manipulations on
+unknown structures such as those decoded from JSON.")
+ (license license:expat)))
(define-public go-github-com-multiformats-go-multiaddr
(let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")
(revision "0"))