summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-21 01:29:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-03 19:27:40 +0100
commit326ec739de90c9de3aad388fe1d7fc701b9abe90 (patch)
tree48d0e67a71ee0ef16bfc1fcd761c75198e089fb7 /gnu
parentd414327a2e3466064b1b3efce08c0cda4f7c7bb1 (diff)
downloadguix-patches-326ec739de90c9de3aad388fe1d7fc701b9abe90.tar
guix-patches-326ec739de90c9de3aad388fe1d7fc701b9abe90.tar.gz
gnu: rust-scoped-tls-1: Drop minor version from name.
* gnu/packages/crates-io.scm (rust-scoped-tls-1): Drop minor version from name. (rust-loom-0.3): (rust-rayon-core-1): (rust-rustc-ap-rustc-ast-654): (rust-rustc-ap-rustc-span-654): (rust-rustc-rayon-core-0.3): (rust-scoped-tls-0.1): (rust-swc-1): (rust-wasm-bindgen-shared-0.2): (rust-wasm-bindgen-test-0.3): Apply removal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f7f007e7f2..04498a9d72 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15805,7 +15805,7 @@ by inspecting the system for user preference.")
(("rust-cfg-if" ,rust-cfg-if-0.1)
("rust-futures-util" ,rust-futures-util-0.3)
("rust-generator" ,rust-generator-0.6)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/tokio-rs/loom")
@@ -24018,7 +24018,7 @@ accessors.")
(("rust-libc" ,rust-libc-0.2)
("rust-rand" ,rust-rand-0.7)
("rust-rand-xorshift" ,rust-rand-xorshift-0.2)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0))))
+ ("rust-scoped-tls" ,rust-scoped-tls-1))))
(home-page "https://github.com/rayon-rs/rayon")
(synopsis "Core APIs for Rayon")
(description "Core APIs for Rayon.")
@@ -25419,7 +25419,7 @@ It is automatically published using the compiler repository at
("rust-rustc-ap-rustc-macros" ,rust-rustc-ap-rustc-macros-654)
("rust-rustc-ap-serialize" ,rust-rustc-ap-serialize-654)
("rust-rustc-ap-rustc-span" ,rust-rustc-ap-rustc-span-654)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-smallvec" ,rust-smallvec-1))))
(home-page "https://github.com/alexcrichton/rustc-auto-publish")
(synopsis
@@ -25583,7 +25583,7 @@ It is automatically published using the compiler repository at
("rust-rustc-ap-rustc-index" ,rust-rustc-ap-rustc-index-654)
("rust-rustc-ap-rustc-macros" ,rust-rustc-ap-rustc-macros-654)
("rust-rustc-ap-serialize" ,rust-rustc-ap-serialize-654)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-sha-1" ,rust-sha-1-0.8)
("rust-unicode-width" ,rust-unicode-width-0.1))))
(home-page "https://github.com/alexcrichton/rustc-auto-publish")
@@ -25782,7 +25782,7 @@ should be using the real rayon crate, not rustc-rayon.")
(("rust-libc" ,rust-libc-0.2)
("rust-rand" ,rust-rand-0.6)
("rust-rand-xorshift" ,rust-rand-xorshift-0.1)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0))))
+ ("rust-scoped-tls" ,rust-scoped-tls-1))))
(home-page "https://github.com/rust-lang/rustc-rayon")
(synopsis "Core APIs for Rayon - fork for rustc")
(description
@@ -26651,7 +26651,7 @@ non-'static references in parallel.")
(license (list license:asl2.0
license:expat))))
-(define-public rust-scoped-tls-1.0
+(define-public rust-scoped-tls-1
(package
(name "rust-scoped-tls")
(version "1.0.0")
@@ -26675,7 +26675,7 @@ library's old @code{scoped_thread_local!} macro for providing scoped access to
(define-public rust-scoped-tls-0.1
(package
- (inherit rust-scoped-tls-1.0)
+ (inherit rust-scoped-tls-1)
(name "rust-scoped-tls")
(version "0.1.2")
(source
@@ -30460,7 +30460,7 @@ cryptographic implementations.")
("rust-regex" ,rust-regex-1)
("rust-relative-path" ,rust-relative-path-1)
("rust-retain-mut" ,rust-retain-mut-0.1)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-st-map" ,rust-st-map-0.1)
("rust-string-cache" ,rust-string-cache-0.8)
("rust-walkdir" ,rust-walkdir-2)
@@ -36212,7 +36212,7 @@ attribute that is not in the shared backend crate.")
`(#:cargo-inputs
(("rust-console-error-panic-hook" ,rust-console-error-panic-hook-0.1)
("rust-js-sys" ,rust-js-sys-0.3)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
("rust-wasm-bindgen-test-macro" ,rust-wasm-bindgen-test-macro-0.3))))
@@ -36242,7 +36242,7 @@ attribute that is not in the shared backend crate.")
(("rust-console-error-panic-hook" ,rust-console-error-panic-hook-0.1)
("rust-futures" ,rust-futures-0.1)
("rust-js-sys" ,rust-js-sys-0.3)
- ("rust-scoped-tls" ,rust-scoped-tls-1.0)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.3)
("rust-wasm-bindgen-test-macro" ,rust-wasm-bindgen-test-macro-0.2))))))