summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-15 15:26:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-25 00:22:06 +0100
commit3258335e229cf8839942a70ff9c7950b87bc3516 (patch)
tree96b02e52010e9eed24aef4c8d8e0883df2266b11 /gnu
parentae63b2d0ffce4770a0aa96d84603b8d56f7608f2 (diff)
downloadguix-patches-3258335e229cf8839942a70ff9c7950b87bc3516.tar
guix-patches-3258335e229cf8839942a70ff9c7950b87bc3516.tar.gz
gnu: python2-faker: Remove package.
* gnu/packages/python-xyz.scm (python2-faker): Delete variable. (python-faker)[properties]: Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 1 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a7a89ba0d..7f178d7454 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16105,29 +16105,7 @@ parsing UK postcodes.")
(description
"Faker is a Python package that generates fake data such as names,
addresses, and phone numbers.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-faker))))))
-
-;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
-(define-public python2-faker
- (let ((base (package-with-python2 (strip-python2-variant
- python-faker))))
- (package
- (inherit base)
- (version "3.0.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Faker" version))
- (sha256
- (base32
- "11cr0qvspkdh6198rqy56qildk7bnp6llj8kyy1dan5sp5n4dxy7"))))
- (native-inputs
- `(("python-mock" ,python2-mock)
- ,@(package-native-inputs base)))
- (propagated-inputs
- `(("python2-ipaddress" ,python2-ipaddress)
- ("python2-six" ,python2-six)
- ,@(package-propagated-inputs base))))))
+ (license license:expat)))
(define-public python-pyaml
(package