summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-02-01 09:50:22 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-04 22:03:30 +0100
commit308d72bfe4fced4cf5b2464e70e458a74b3598cc (patch)
tree29638fcfd5132179187fc2e483bf6085ef6413bf /gnu
parentb2c2c415c53d0747ca62a4807264f182d97b8382 (diff)
downloadguix-patches-308d72bfe4fced4cf5b2464e70e458a74b3598cc.tar
guix-patches-308d72bfe4fced4cf5b2464e70e458a74b3598cc.tar.gz
gnu: Add ocaml-ppx-inline-test.
* gnu/packages/ocaml.scm (ocaml-ppx-inline-test): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a1f9e7996b..28f1c99e4c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4694,6 +4694,38 @@ Dedukti files.")
syntax checking on dedukti files.")
(license license:cecill-b))))
+(define-public ocaml-ppx-inline-test
+ (package
+ (name "ocaml-ppx-inline-test")
+ (version "0.11.0")
+ (home-page "https://github.com/janestreet/ppx_inline_test")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11n94fz1asjf5vqdgriv0pvsa5lbfpqcyk525c7816w23vskcvq6"))))
+ (build-system dune-build-system)
+ (arguments
+ ;see home page README for further information
+ `(#:tests? #f))
+ (inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-compiler-libs" ,ocaml-compiler-libs)
+ ("ocaml-sexplib0" ,ocaml-sexplib0)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (synopsis "Syntax extension for writing in-line tests in ocaml code")
+ (description "This package contains a syntax extension for writing
+in-line tests in ocaml code. It is part of Jane Street's PPX rewriters
+collection.")
+ (license license:expat)))
+
(define-public ocaml-biniou
(package
(name "ocaml-biniou")