summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:12:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:18 +0300
commit26db4c956dba32b1a3cdaed675915f6d34c84b3e (patch)
tree451c4f1477bffae0cd7361f5ed7d831f90e219bd /gnu
parentc08dd5c5f9cb4505b19e2561c693c7af76836fdc (diff)
downloadguix-patches-26db4c956dba32b1a3cdaed675915f6d34c84b3e.tar
guix-patches-26db4c956dba32b1a3cdaed675915f6d34c84b3e.tar.gz
gnu: Add go-github-com-masterminds-sprig.
* gnu/packages/golang.scm (go-github-com-masterminds-sprig): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 83d28cbaac..4711ce937d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4440,4 +4440,37 @@ zero-value fields. Mergo won't merge unexported (private) fields. It will do
recursively any exported one. It also won't merge structs inside
maps (because they are not addressable using Go reflection).")
(license license:bsd-3)))
+
+(define-public go-github-com-masterminds-sprig
+ (package
+ (name "go-github-com-masterminds-sprig")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/sprig")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wwi8n2adjc5jlga25lqq0hrz4jcgd5vpll68y2dfji034caaq18"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ;network tests only
+ #:import-path "github.com/Masterminds/sprig"))
+ (native-inputs
+ `(("go-github-com-masterminds-goutils" ,go-github-com-masterminds-goutils)
+ ("go-github-com-masterminds-semver" ,go-github-com-masterminds-semver)
+ ("go-github-com-google-uuid" ,go-github-com-google-uuid)
+ ("go-github-com-huandu-xstrings" ,go-github-com-huandu-xstrings)
+ ("go-github-com-imdario-mergo" ,go-github-com-imdario-mergo)
+ ("go-github-com-mitchellh-reflectwalk" ,go-github-com-mitchellh-reflectwalk)
+ ("go-github-com-mitchellh-copystructure" ,go-github-com-mitchellh-copystructure)
+ ("go-github-com-spf13-cast" ,go-github-com-spf13-cast)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+ (home-page "https://github.com/Masterminds/sprig/")
+ (synopsis "Template functions for Go templates")
+ (description "Sprig is a library that provides more than 100 commonly used
+template functions.")
(license license:expat)))