summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 16:05:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 16:05:47 +0300
commit2313be9041202e3285622a9de9e599afc8e44f29 (patch)
treee9974930f16a5e5bca8b15383c8b0c8c3260783e /gnu
parentff7a6c6d5b542c8a54fb00b55bbd4c663731408a (diff)
downloadguix-patches-2313be9041202e3285622a9de9e599afc8e44f29.tar
guix-patches-2313be9041202e3285622a9de9e599afc8e44f29.tar.gz
gnu: python-pifpaf: Enable tests.
* gnu/packages/python-xyz.scm (python-pifpaf)[arguments]: Enable tests. Use custom 'check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d509d51f4e..8350e4ed92 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19902,7 +19902,12 @@ logging in Python. It also provides some custom formatters and handlers.")
"150av2pylsjy8ykrpyi0vzy2q24s9rhh2ya01zvwnvj9j5dspviz"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "setup.py" "testr" "--slowest"
+ "--testr-args=until-failure"))))))
(propagated-inputs
`(("python-click" ,python-click)
("python-daiquiri" ,python-daiquiri)