summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:46:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:26 +0300
commit1fde30c2902808d6c11dd612c1131f0cd24372a3 (patch)
tree7f02a5bd3489f05dd36d167a4eda8a66829ad9c6 /gnu
parent50255943b178015ac176bc073445681eac299550 (diff)
downloadguix-patches-1fde30c2902808d6c11dd612c1131f0cd24372a3.tar
guix-patches-1fde30c2902808d6c11dd612c1131f0cd24372a3.tar.gz
gnu: Add julia-rotations.
* gnu/packages/julia-xyz.scm (julia-rotations): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 03f7cc7cf8..76cbc1de7c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2343,6 +2343,35 @@ high-order accuracy, assuming that @code{f(x0+h)} has a Taylor series or some
other power series in @code{h}.")
(license license:expat)))
+(define-public julia-rotations
+ (package
+ (name "julia-rotations")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaGeometry/Rotations.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l1a3bnrpv9qdksnk3c8j82ik3yrnpsmnyxyiy3gc1yjya5pajqj"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-staticarrays" ,julia-staticarrays)))
+ (native-inputs
+ `(("julia-benchmarktools" ,julia-benchmarktools)
+ ("julia-forwarddiff" ,julia-forwarddiff)
+ ("julia-unitful" ,julia-unitful)))
+ (home-page "https://github.com/JuliaGeometry/Rotations.jl")
+ (synopsis "Julia implementations for different rotation parameterisations")
+ (description "This package implements various 3D rotation parameterizations
+and defines conversions between them. At their heart, each rotation
+parameterization is a 3×3 unitary (orthogonal) matrix (based on the
+@code{StaticArrays.jl} package), and acts to rotate a 3-vector about the origin
+through matrix-vector multiplication.")
+ (license license:expat)))
+
(define-public julia-safetestsets
;; The only release tag is the first commit in the repository.
(let ((commit "e553edc4c753344d38349304b9ff5483c3b8ff21")