summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 17:35:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-20 19:31:42 +0100
commit5eb86b64d19ea1afeb1f6f21994a29ebbd9005b8 (patch)
tree8092030409b869deb109babc8d511f2f777e13be /gnu
parentf78c66aacc6057ffb83c53631686dc1f0798c472 (diff)
downloadguix-patches-5eb86b64d19ea1afeb1f6f21994a29ebbd9005b8.tar
guix-patches-5eb86b64d19ea1afeb1f6f21994a29ebbd9005b8.tar.gz
gnu: Add libyaml.
* gnu/packages/web.scm (libyaml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 308434f27f..5296c43c53 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -799,3 +799,23 @@ select or poll.")
server). It was primarily designed to be used by one person or a small group
of people.")
(license l:expat)))
+
+(define-public libyaml
+ (package
+ (name "libyaml")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://pyyaml.org/download/libyaml/yaml-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1vrv5ly58bkmcyc049ad180f2m8iav6l9h3v8l2fqdmrny7yx1zs"))))
+ (build-system gnu-build-system)
+ (home-page "http://pyyaml.org/wiki/LibYAML")
+ (synopsis "YAML 1.1 parser and emitter written in C")
+ (description
+ "LibYAML is a YAML 1.1 parser and emitter written in C.")
+ (license l:expat)))