summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-11 17:08:45 +0200
committerMarius Bakke <marius@gnu.org>2020-10-13 23:48:16 +0200
commit5e5b664bf7434e0ecbacd6f52c5da38654c76fd9 (patch)
tree4312158bf5176551c979f80d9c7b9d3eb4d2e546 /gnu
parent9e1f5a263e4f6df4d075901c9b58a56f80c8b452 (diff)
downloadguix-patches-5e5b664bf7434e0ecbacd6f52c5da38654c76fd9.tar
guix-patches-5e5b664bf7434e0ecbacd6f52c5da38654c76fd9.tar.gz
gnu: libcap: Update to 2.44.
* gnu/packages/linux.scm (libcap): Update to 2.44. [arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 293b873fc2..c9f7af0a8e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2450,7 +2450,7 @@ Linux-based operating systems.")
(define-public libcap
(package
(inherit libcap-2.31)
- (version "2.34")
+ (version "2.44")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2458,7 +2458,19 @@ Linux-based operating systems.")
"libcap2/libcap-" version ".tar.xz"))
(sha256
(base32
- "048n1gy2p48vl9hkrr9wymfxxcpwj2aslz2bv79nhl4m2lhd9kdf"))))))
+ "1qf80lifygbnxwvqjf8jz5j24n6fqqx4ixnkbf76xs2vrmcq664j"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments libcap-2.31)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'configure
+ (lambda _
+ ;; Add $libdir to the RUNPATH of executables.
+ (substitute* "Make.Rules"
+ (("LDFLAGS \\?= #-g")
+ (string-append "LDFLAGS ?= -Wl,-rpath="
+ %output "/lib")))
+ #t))))))))
(define-deprecated libcap/next libcap)
(export libcap/next)