summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-16 21:52:58 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-16 21:52:58 +0100
commit5078e98a61a4e149f8470fcae4673e1e03ac1a3a (patch)
tree6332fceebce23d82d2e0474affb3144b329e239b /gnu
parent3e291958b0c0288f7a7c1b47eb4a81face06e645 (diff)
downloadguix-patches-5078e98a61a4e149f8470fcae4673e1e03ac1a3a.tar
guix-patches-5078e98a61a4e149f8470fcae4673e1e03ac1a3a.tar.gz
gnu: Add aarddict.
* gnu/packages/aarddict.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/aarddict.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/aarddict.scm b/gnu/packages/aarddict.scm
new file mode 100644
index 0000000000..33bd7b4ac9
--- /dev/null
+++ b/gnu/packages/aarddict.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages aarddict)
+ #:use-module ((guix licenses) #:select (gpl3))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt))
+
+(define-public aarddict
+ (package
+ (name "aarddict")
+ (version "0.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/aarddict/desktop/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12h7m0z7nd7rg8avpi9syd265k0rhh4vbdh464nq0jzdg8m9p28c"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python2-pyicu" ,python2-pyicu)
+ ("python2-pyqt-4" ,python2-pyqt-4)
+ ("python2-setuptools" ,python2-setuptools)
+ ("python2-simplejson" ,python2-simplejson)
+ ("python2-sip" ,python2-sip)))
+ (arguments
+ `(#:python ,python-2 ; incompatible with Python 3
+ #:phases
+ (alist-cons-before
+ 'build 'configure
+ ;; Force data into the output instead of the python package.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "setup.py"
+ (("sys.prefix") (string-append "'" out "'")))))
+ %standard-phases)))
+ (home-page "http://aarddict.org/index.html")
+ (synopsis
+ "Dictionary program and offline Wikipedia reader")
+ (description
+ "Aard Dictionary is a free, fast, easy to use word lookup program that
+looks up words fast even with huge dictionaries like English Wikipedia;
+looks up words in multiple dictionaries in multiple languages without
+switching;
+works great as offline Wikipedia reader;
+is keyboard navigation friendly;
+has efficient, highly compressed dictionary data storage format with
+ability to verify data integrity built-in.")
+ (license gpl3)))