summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-18 15:30:22 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-18 16:32:47 +0200
commitb5fb9430ba29ef80661a7730717399bf54f7115b (patch)
tree9fde6649e94625a8a512811f49b1be2018d7e47c /gnu
parent2b3b745c00bda3a3cf2602ac8db57cd2634e20c5 (diff)
downloadguix-patches-b5fb9430ba29ef80661a7730717399bf54f7115b.tar
guix-patches-b5fb9430ba29ef80661a7730717399bf54f7115b.tar.gz
gnu: multipath-tools: Don't install to /usr sub-folders.
* gnu/packages/linux.scm (multipath-tools)<#:make-flags>: Add SYSTEMDPATH entry. <#:phases>: Add new 'patch-source' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9730838e3e..968aa9b58f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2630,11 +2630,17 @@ arrays when needed.")
'(#:tests? #f ; No tests.
#:make-flags (list (string-append "DESTDIR="
(assoc-ref %outputs "out"))
+ "SYSTEMDPATH=lib"
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "Makefile.inc"
+ (("\\$\\(prefix\\)/usr") "$(prefix)"))
+ #t))
(delete 'configure)
(add-before 'build 'set-CC
(lambda _