summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:37:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:49 +0100
commitb2e777b27cb677592f7a72fef491ec476d7ae65a (patch)
treea6d808f9639c99da340d78e1a423997b9d7580dc /gnu
parentadcd0cc87e89ddcdb484493ca100a51fe9e491c0 (diff)
downloadguix-patches-b2e777b27cb677592f7a72fef491ec476d7ae65a.tar
guix-patches-b2e777b27cb677592f7a72fef491ec476d7ae65a.tar.gz
gnu: Add r-tfmpvalue.
* gnu/packages/cran.scm (r-tfmpvalue): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index aa9a063a76..16d576ecee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9024,3 +9024,29 @@ stack groups of columns and to reshape wide data, even when the data are
and which @code{melt} and @code{dcast} from @code{reshape2} do not easily
handle.")
(license license:gpl3)))
+
+(define-public r-tfmpvalue
+ (package
+ (name "r-tfmpvalue")
+ (version "0.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "TFMPvalue" version))
+ (sha256
+ (base32
+ "0h9qkl15k8v17v3g9bdnfwvh2s04ywjgg5y0xn2077dmywlja1bd"))))
+ (properties `((upstream-name . "TFMPvalue")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/ge11232002/TFMPvalue")
+ (synopsis "P-value computation for position weight matrices")
+ (description
+ "In putative @dfn{Transcription Factor Binding Sites} (TFBSs)
+identification from sequence/alignments, we are interested in the significance
+of certain match scores. TFMPvalue provides the accurate calculation of a
+p-value with a score threshold for position weight matrices, or the score with
+a given p-value. It is an interface to code originally made available by
+Helene Touzet and Jean-Stephane Varre, 2007, Algorithms Mol Biol:2, 15.
+Touzet and Varre (2007).")
+ (license license:gpl2)))