summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-05 15:03:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-06-05 15:04:49 +0200
commit9e20646bf5210c8068150c9f75983badb6fd249c (patch)
treed6d4bea9d5ed677e8176243553f561e9a9e26424 /gnu
parent019ff3c3c74048a133263ccacac3db87e52bc00a (diff)
downloadguix-patches-9e20646bf5210c8068150c9f75983badb6fd249c.tar
guix-patches-9e20646bf5210c8068150c9f75983badb6fd249c.tar.gz
gnu: Add cl-prometheus.pushgateway.
* gnu/packages/lisp-xyz.scm (sbcl-prometheus.pushgateway, cl-prometheus.pushgateway, ecl-prometheus.pushgateway): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3156bc9de2..591615f4d1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11683,3 +11683,20 @@ Streams in ICDE’05.")
(define-public cl-prometheus.exposers.hunchentoot
(sbcl-package->cl-source-package sbcl-prometheus.exposers.hunchentoot))
+
+(define-public sbcl-prometheus.pushgateway
+ (package
+ (inherit sbcl-prometheus)
+ (name "sbcl-prometheus.pushgateway")
+ (inputs
+ `(("drakma" ,sbcl-drakma)
+ ("prometheus" ,sbcl-prometheus)
+ ("prometheus.formats.text" ,sbcl-prometheus.formats.text)))
+ (synopsis "Prometheus Pushgateway client")
+ (description "Prometheus Pushgateway client.")))
+
+(define-public cl-prometheus.pushgateway
+ (sbcl-package->cl-source-package sbcl-prometheus.pushgateway))
+
+(define-public ecl-prometheus.pushgateway
+ (sbcl-package->ecl-package sbcl-prometheus.pushgateway))