summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:36:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commit99c164a5c7a4c17a7d8770a4ec86906cb67b61d6 (patch)
treea41916bae38b46e5a462a6eef08fb8d3b044dc2c /gnu
parent32725458b744c46f0635ba9f73e1ba6c77477e4a (diff)
downloadguix-patches-99c164a5c7a4c17a7d8770a4ec86906cb67b61d6.tar
guix-patches-99c164a5c7a4c17a7d8770a4ec86906cb67b61d6.tar.gz
gnu: Add r-spatialextremes.
* gnu/packages/cran.scm (r-spatialextremes): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70128d376c..a3bc01ba0d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9980,3 +9980,31 @@ emphasis on splines, spatial data and spatial statistics. The major methods
include cubic, and thin plate splines, Kriging, and compactly supported
covariance functions for large data sets.")
(license license:gpl2+)))
+
+(define-public r-spatialextremes
+ (package
+ (name "r-spatialextremes")
+ (version "2.0-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SpatialExtremes" version))
+ (sha256
+ (base32
+ "1y0h1pcfqp9ynxsr3yrfbihlwm25ypyb88jmm5k2g7xvm8h9g050"))))
+ (properties
+ `((upstream-name . "SpatialExtremes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fields" ,r-fields)
+ ("r-maps" ,r-maps)))
+ (home-page "http://spatialextremes.r-forge.r-project.org/")
+ (synopsis "Modelling spatial extremes")
+ (description
+ "This package provides tools for the statistical modelling of spatial
+extremes using max-stable processes, copula or Bayesian hierarchical models.
+More precisely, this package allows (conditional) simulations from various
+parametric max-stable models, analysis of the extremal spatial dependence, the
+fitting of such processes using composite likelihoods or least square (simple
+max-stable processes only), model checking and selection and prediction.")
+ (license license:gpl2+)))