summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:31:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:51 +0100
commit90104ecd66526e708df0fca2cc6e93de89401883 (patch)
tree828b204169c620494fdc88380cb0bba94dad09ec /gnu
parentf51dcc275e6c4de9b95e7a5d8584a307a259a0db (diff)
downloadguix-patches-90104ecd66526e708df0fca2cc6e93de89401883.tar
guix-patches-90104ecd66526e708df0fca2cc6e93de89401883.tar.gz
gnu: Add r-spam.
* gnu/packages/cran.scm (r-spam): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4020ecdf9e..e13fbc67cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9924,3 +9924,33 @@ supports long vectors, arguments of type 64-bit integer, and provides a
mechanism to avoid unnecessary copies of read-only and write-only arguments.
This makes it a convenient and fast interface to C/C++ and Fortran code.")
(license license:gpl2+)))
+
+(define-public r-spam
+ (package
+ (name "r-spam")
+ (version "2.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "spam" version))
+ (sha256
+ (base32
+ "04bfwwna013hrbl4k6w1cdiz5bkc83jlasivriyn5l9gkj2qskr2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dotcall64" ,r-dotcall64)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://www.math.uzh.ch/pages/spam/")
+ (synopsis "Sparse matrix algebra")
+ (description
+ "This package provides a set of functions for sparse matrix algebra.
+Differences with other sparse matrix packages are:
+
+@enumerate
+@item it only supports (essentially) one sparse matrix format;
+@item it is based on transparent and simple structure(s);
+@item it is tailored for MCMC calculations within G(M)RF;
+@item and it is fast and scalable (with the extension package @code{spam64}).
+@end enumerate\n")
+ ;; Either of these licenses
+ (license (list license:bsd-3 license:lgpl2.0))))