summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 17:09:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commit879a15203b349d464a47b708a2ab37f09c3e36a3 (patch)
tree53522343fd1f48433fce19dd9725b4e474df54a6 /gnu
parent17932a0f63f54bb6ad37d773dfd9fad4e8c7146b (diff)
downloadguix-patches-879a15203b349d464a47b708a2ab37f09c3e36a3.tar
guix-patches-879a15203b349d464a47b708a2ab37f09c3e36a3.tar.gz
gnu: Add r-ppls.
* gnu/packages/cran.scm (r-ppls): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c0142d092..68e660a9a3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10287,3 +10287,25 @@ Age-Period-Cohort and Lee-Carter modeling and a function for interval censored
data and some useful functions for tabulation and plotting, as well as a
number of epidemiological data sets.")
(license license:gpl2)))
+
+(define-public r-ppls
+ (package
+ (name "r-ppls")
+ (version "1.6-1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ppls" version))
+ (sha256
+ (base32
+ "1zyrisy3c4cz896j1bjh61sf57wdl9p8ywdq268cl819szfq78mx"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ppls")
+ (synopsis "Penalized partial least squares")
+ (description
+ "This package contains linear and nonlinear regression methods based on
+partial least squares and penalization techniques. Model parameters are
+selected via cross-validation, and confidence intervals ans tests for the
+regression coefficients can be conducted via jackknifing.")
+ (license license:gpl2+)))