summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-04 17:27:41 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-04 17:27:41 +0100
commitaebaeaee33231d5027dc26c05ac510e8324af3dd (patch)
tree3adeff9adfdd3eb160e4c9fa0e380ec5d5ea8f90 /gnu
parent64cc58b24971493cd296eaa9cd78a83c46f1bab3 (diff)
downloadguix-patches-aebaeaee33231d5027dc26c05ac510e8324af3dd.tar
guix-patches-aebaeaee33231d5027dc26c05ac510e8324af3dd.tar.gz
gnu: lsh: Fix the absolute file name of 'sexp-conv'.
* gnu/packages/lsh.scm (lsh): Rename 'fix-test-suite' phase to 'pre-configure'. Set PATH_SEXP_CONV in environ.h.in.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lsh.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/lsh.scm b/gnu/packages/lsh.scm
index e9e5976fb4..afdf16bf55 100644
--- a/gnu/packages/lsh.scm
+++ b/gnu/packages/lsh.scm
@@ -95,8 +95,17 @@ basis for almost any application.")
#:phases
(alist-cons-before
- 'configure 'fix-test-suite
- (lambda _
+ 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place by
+ ;; default.
+ (substitute* "src/environ.h.in"
+ (("^#define PATH_SEXP_CONV.*")
+ (let* ((nettle (assoc-ref inputs "nettle"))
+ (sexp-conv (string-append nettle "/bin/sexp-conv")))
+ (string-append "#define PATH_SEXP_CONV \""
+ sexp-conv "\"\n"))))
+
;; Tests rely on $USER being set.
(setenv "USER" "guix")