summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2021-10-15 11:40:35 +0900
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:43 +0200
commit271343d4f57455bb696d760d7244c6b36700cdc6 (patch)
treeb131a5a22da45a351b3ad87ea2a7bbdb04d98f90 /gnu
parentfafb7ab1e20696f799c30bfc55d30c7626c8b3a4 (diff)
downloadguix-patches-271343d4f57455bb696d760d7244c6b36700cdc6.tar
guix-patches-271343d4f57455bb696d760d7244c6b36700cdc6.tar.gz
gnu: python-faker: Fix indentation.
* gnu/packages/python-xyz.scm (python-faker): Fix indentation. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7142d5a294..33fb3082b7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15887,37 +15887,37 @@ parsing UK postcodes.")
(define-public python-faker
(package
- (name "python-faker")
- (version "9.3.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Faker" version))
- (sha256
- (base32
- "0lpfdc4ndvk7chgqrfd2b1my4n54pccq9b645vp9cp5s5ypyknfd"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (invoke "python" "-m" "pytest" "-v"))))))
- (native-inputs
- `(;; For testing
- ("python-freezegun" ,python-freezegun)
- ("python-pytest" ,python-pytest-6)
- ("python-random2" ,python-random2)
- ("python-ukpostcodeparser" ,python-ukpostcodeparser)
- ("python-validators" ,python-validators)))
- (propagated-inputs
- `(("python-dateutil" ,python-dateutil)
- ("python-text-unidecode" ,python-text-unidecode)))
- (home-page "https://github.com/joke2k/faker")
- (synopsis "Python package that generates fake data")
- (description
- "Faker is a Python package that generates fake data such as names,
+ (name "python-faker")
+ (version "9.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Faker" version))
+ (sha256
+ (base32
+ "0lpfdc4ndvk7chgqrfd2b1my4n54pccq9b645vp9cp5s5ypyknfd"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "python" "-m" "pytest" "-v"))))))
+ (native-inputs
+ `( ;; For testing
+ ("python-freezegun" ,python-freezegun)
+ ("python-pytest" ,python-pytest-6)
+ ("python-random2" ,python-random2)
+ ("python-ukpostcodeparser" ,python-ukpostcodeparser)
+ ("python-validators" ,python-validators)))
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-text-unidecode" ,python-text-unidecode)))
+ (home-page "https://github.com/joke2k/faker")
+ (synopsis "Python package that generates fake data")
+ (description
+ "Faker is a Python package that generates fake data such as names,
addresses, and phone numbers.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-faker))))))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-faker))))))
;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
(define-public python2-faker