summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-16 12:27:11 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-16 12:27:39 +0100
commit703a095e7ec3c8247deb527f027615e5e34fe753 (patch)
tree0cdb1cb2851f75d17198214158e3d56269f51d5a /gnu
parent54f51df6811ffd6456196350581cf6ef6637c2b9 (diff)
downloadguix-patches-703a095e7ec3c8247deb527f027615e5e34fe753.tar
guix-patches-703a095e7ec3c8247deb527f027615e5e34fe753.tar.gz
gnu: emacs-helm-system-packages: Update to 20190316.
* gnu/packages/emacs-xyz.scm (emacs-helm-system-packages): Update to 20190316.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm66
1 files changed, 35 insertions, 31 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cef6c7245c..e2508509c9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5869,42 +5869,46 @@ Yasnippet.")
(license license:gpl2+))))
(define-public emacs-helm-system-packages
- (package
- (name "emacs-helm-system-packages")
- (version "1.10.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-helm/helm-system-packages")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "01by0c4lqi2cw8xmbxkjw7m9x78zssm31sx4hdpw5j35s2951j0f"))))
- (build-system emacs-build-system)
- (inputs
- `(("recutils" ,recutils)))
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((recutils (assoc-ref inputs "recutils")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (substitute* "helm-system-packages-guix.el"
- (("recsel") (string-append recutils "/bin/recsel")))))))))
- (home-page "https://github.com/emacs-helm/helm-system-packages")
- (synopsis "Helm System Packages is an interface to your package manager")
- (description "List all available packages in Helm (with installed
+ ;; There won't be a new release after 1.10.1 until
+ ;; https://github.com/emacs-helm/helm-system-packages/issues/25 is fixed,
+ ;; and latest commits fix import issues with Guix.
+ (let ((commit "6572340f41611ef1991e9612d34d59130957ee4a"))
+ (package
+ (name "emacs-helm-system-packages")
+ (version (git-version "1.10.1" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-system-packages")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mcz6vkpk12vsyd37xv1rbg4v442sxc3lj8yxskqg294xbdaclz4"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("recutils" ,recutils)))
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((recutils (assoc-ref inputs "recutils")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (substitute* "helm-system-packages-guix.el"
+ (("recsel") (string-append recutils "/bin/recsel")))))))))
+ (home-page "https://github.com/emacs-helm/helm-system-packages")
+ (synopsis "Helm System Packages is an interface to your package manager")
+ (description "List all available packages in Helm (with installed
packages displayed in their own respective face). Fuzzy-search, mark and
execute the desired action over any selections of packages: Install,
uninstall, display packages details (in Org Mode) or insert details at point,
find files owned by packages... And much more, including performing all the
above over the network.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-memoize
(package