summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-10 14:22:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-10 14:22:57 +0200
commit8e344e36771e35702ab3e4bef72529dcd3498809 (patch)
treecba164d2258e2d314814d79a1a8ddc3fe7ca8821 /gnu
parent3fdb01f1f5a5f7cdf347a43ecc00a62df3a5ca8d (diff)
downloadguix-patches-8e344e36771e35702ab3e4bef72529dcd3498809.tar
guix-patches-8e344e36771e35702ab3e4bef72529dcd3498809.tar.gz
gnu: singularity: Update command substitutions.
Reported by Hao Chen <hchen@uthsc.edu>. * gnu/packages/linux.scm (singularity)[arguments]: Update 'patch-references phase to actually patch mksquashfs calls and to patch sed calls.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ee460c38b2..4b1fe7e15a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4045,18 +4045,18 @@ thanks to the use of namespaces.")
(modify-phases %standard-phases
(add-after 'unpack 'patch-references
(lambda _
- (substitute* "libexec/cli/build.exec"
- (("if ! singularity_which mksquashfs") "if 0")
- (("if ! mksquashfs")
- (string-append "if ! " (which "mksquashfs"))))
- (substitute* (list "libexec/cli/help.exec"
- "libexec/bootstrap-scripts/functions"
- "libexec/bootstrap-scripts/post.sh"
- "libexec/functions")
+ (substitute* "libexec/cli/build.exec.in"
+ (("-mksquashfs") (string-append "-" (which "mksquashfs"))))
+ (substitute* (append
+ (find-files "libexec" "functions")
+ (find-files "libexec/bootstrap-scripts" ".*sh$")
+ (find-files "libexec/cli" ".*exec$"))
(("\\| grep ")
(string-append "| " (which "grep") " "))
(("egrep ")
- (string-append (which "egrep") " ")))
+ (string-append (which "egrep") " "))
+ ((" sed ")
+ (string-append " " (which "sed") " ")))
#t))
(add-after 'install 'set-PATH
(lambda* (#:key inputs outputs #:allow-other-keys)