summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-16 12:46:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-16 12:49:05 +0300
commit6675cd8c2408e8eecf652950da2b1a13df66c6d6 (patch)
treeafd7e77263e698a8a3ccb82f0604c8c912a72a92 /gnu
parent76a841cc8bd091db741758ae5553c714f2c38543 (diff)
downloadguix-patches-6675cd8c2408e8eecf652950da2b1a13df66c6d6.tar
guix-patches-6675cd8c2408e8eecf652950da2b1a13df66c6d6.tar.gz
gnu: Add rust-static-assertions-1.
* gnu/packages/crates-io.scm (rust-static-assertions-1): New variable. (rust-static-assertions-0.3): Inherit from rust-static-assertions-1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 30e00b3f48..c7145c84ee 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21861,10 +21861,10 @@ deeply recursive algorithms that may accidentally blow the stack.")
"StackVec: vector-like facade for stack-allocated arrays.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-static-assertions-0.3
+(define-public rust-static-assertions-1
(package
(name "rust-static-assertions")
- (version "0.3.4")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -21872,7 +21872,7 @@ deeply recursive algorithms that may accidentally blow the stack.")
(file-name (string-append name "-" version ".crate"))
(sha256
(base32
- "1lw33i89888yb3x29c6dv4mrkg3534n0rlg3r7qzh4p58xmv6gkz"))))
+ "0gsl6xmw10gvn3zs1rv99laj5ig7ylffnh71f9l34js4nr4r7sx2"))))
(build-system cargo-build-system)
(home-page "https://github.com/nvzqz/static-assertions-rs")
(synopsis "Compile-time assertions for rust")
@@ -21881,6 +21881,20 @@ deeply recursive algorithms that may accidentally blow the stack.")
are met.")
(license (list license:expat license:asl2.0))))
+(define-public rust-static-assertions-0.3
+ (package
+ (inherit rust-static-assertions-1)
+ (name "rust-static-assertions")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "static-assertions" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1lw33i89888yb3x29c6dv4mrkg3534n0rlg3r7qzh4p58xmv6gkz"))))))
+
(define-public rust-stb-truetype-0.3
(package
(name "rust-stb-truetype")