summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-07 21:55:27 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-07 22:07:01 +0100
commit3c85058c0e29fdff5269cff58f43dfbad92259b6 (patch)
tree9691b36ce338205af1041e54780eb1cfbb7719a1 /gnu
parentf31ce9ecf1ecb4eeab4fc37792684b3fa03ec95f (diff)
downloadguix-patches-3c85058c0e29fdff5269cff58f43dfbad92259b6.tar
guix-patches-3c85058c0e29fdff5269cff58f43dfbad92259b6.tar.gz
gnu: libnet: Update to 1.2-rc3.
* gnu/packages/networking.scm (libnet): Update to 1.2-rc3. [source]: Use git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7b0b15449..3b0714865d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
@@ -1712,15 +1712,17 @@ interface and a programmable text output for scripting.")
(define-public libnet
(package
(name "libnet")
- (version "1.1.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/sam-github/libnet/"
- "archive/libnet-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0l4gbzzvr199fzczzricjz7b825i7dlk6sgl5p5alnkcagmq0xys"))))
+ (version "1.2-rc3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sam-github/libnet")
+ (commit (string-append "libnet-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cy8w4g5rv963v4p6iq3333kxgdddx2lywp70xf62553a25xhhs4"))))
(build-system gnu-build-system)
(arguments
`(#:phases