summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-06-02 08:20:18 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-14 23:02:36 +0200
commit267be609f7b9dcdea86d64f10d52284a36cb7216 (patch)
treeb19d951a91690c1f01d9b9b82049efa9f15e294d /gnu
parentc924e541390f9595d819edc33c19d979917c15ec (diff)
downloadguix-patches-267be609f7b9dcdea86d64f10d52284a36cb7216.tar
guix-patches-267be609f7b9dcdea86d64f10d52284a36cb7216.tar.gz
gnu: Add emacs-erc-status-sidebar.
* gnu/packages/emacs-xyz.scm (emacs-erc-status-sidebar): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index af379902a1..1d465ed66d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3289,6 +3289,31 @@ appropriate console.")
IRC bouncer with ERC.")
(license license:expat)))
+(define-public emacs-erc-status-sidebar
+ (let ((commit "ea4189a1dbfe60117359c36e681ad7c389e2968c")
+ (revision "1"))
+ (package
+ (name "emacs-erc-status-sidebar")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/drewbarbs/erc-status-sidebar.git")
+ (commit commit)))
+ (sha256
+ (base32 "1hwlhzgx03z8891sblz56zdp8zj0izh72kxykgcnz5rrkyc3vfi3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-seq" ,emacs-seq)))
+ (home-page "https://github.com/drewbarbs/erc-status-sidebar")
+ (synopsis "A hexchat-like activity overview for ERC channels")
+ (description
+ "This package is provides a hexchat-like status bar for joined
+channels in ERC. It relies on the `erc-track' module, and displays
+all the same information erc-track does in the mode line, but in an
+alternative format.")
+ (license license:expat))))
+
(define-public emacs-shut-up
(package
(name "emacs-shut-up")