summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-01 18:28:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-01 22:38:25 +0100
commitfd05d7ecd9f021b6c52a6d27669188b44305c79d (patch)
tree86c6d8408df2ea598327362aad3ffa84f967f3d2 /gnu
parent47055b273a7d616ec4362e439287914b442797a3 (diff)
downloadguix-patches-fd05d7ecd9f021b6c52a6d27669188b44305c79d.tar
guix-patches-fd05d7ecd9f021b6c52a6d27669188b44305c79d.tar.gz
gnu: libevent: Skip tests that fail on 32bit.
* gnu/packages/patches/libevent-2.1-skip-failing-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/libevent.scm (libevent)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libevent.scm5
-rw-r--r--gnu/packages/patches/libevent-2.1-skip-failing-test.patch24
3 files changed, 29 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index da4dbb0d24..ac167b23fa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -676,6 +676,7 @@ dist_patch_DATA = \
%D%/packages/patches/libevent-2.0-evdns-fix-searching-empty-hostnames.patch \
%D%/packages/patches/libevent-2.0-evutil-fix-buffer-overflow.patch \
%D%/packages/patches/libevent-2.1-dns-tests.patch \
+ %D%/packages/patches/libevent-2.1-skip-failing-test.patch \
%D%/packages/patches/libextractor-ffmpeg-3.patch \
%D%/packages/patches/libjxr-fix-function-signature.patch \
%D%/packages/patches/libjxr-fix-typos.patch \
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index ca59db390c..bef09f9538 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -43,7 +43,10 @@
(sha256
(base32
"1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
- (patches (search-patches "libevent-2.1-dns-tests.patch"))))
+ (patches (search-patches "libevent-2.1-dns-tests.patch"
+ ;; XXX: Try removing this for > 2.1.8.
+ ;; https://github.com/libevent/libevent/issues/452
+ "libevent-2.1-skip-failing-test.patch"))))
(build-system gnu-build-system)
(inputs
`(("python" ,python-2))) ; for 'event_rpcgen.py'
diff --git a/gnu/packages/patches/libevent-2.1-skip-failing-test.patch b/gnu/packages/patches/libevent-2.1-skip-failing-test.patch
new file mode 100644
index 0000000000..d9ea1d422d
--- /dev/null
+++ b/gnu/packages/patches/libevent-2.1-skip-failing-test.patch
@@ -0,0 +1,24 @@
+These fail on 32-bit due to an overflow bug in the test program.
+
+See test/regress_util.c:1448.
+
+Upstream bug URL:
+
+https://github.com/libevent/libevent/issues/452
+
+diff --git a/test/regress_util.c b/test/regress_util.c
+index ef6a1487..4de501fc 100644
+--- a/test/regress_util.c
++++ b/test/regress_util.c
+@@ -1413,9 +1413,9 @@ static struct date_rfc1123_case {
+ { 1323648000, "Mon, 12 Dec 2011 00:00:00 GMT"},
+ #ifndef _WIN32
+ /** In win32 case we have max "23:59:59 January 18, 2038, UTC" for time32 */
+- { 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
++ //{ 4294967296, "Sun, 07 Feb 2106 06:28:16 GMT"} /* 2^32 */,
+ /** In win32 case we have max "23:59:59, December 31, 3000, UTC" for time64 */
+- {253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
++ //{253402300799, "Fri, 31 Dec 9999 23:59:59 GMT"} /* long long future no one can imagine */,
+ { 1456704000, "Mon, 29 Feb 2016 00:00:00 GMT"} /* leap year */,
+ #endif
+ { 1435708800, "Wed, 01 Jul 2015 00:00:00 GMT"} /* leap second */,