summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-02-01 22:43:13 +0530
committerKei Kebreau <kei@openmailbox.org>2017-02-01 14:45:06 -0500
commit5430dbd95b812d8fa566725885d50ba4024402eb (patch)
treefc6cdf0e8795ea5314ddfdf8a502a70b79cf1997 /gnu
parent36df995c94cfbda4b7874de1d69d3f44b0e73c7e (diff)
downloadguix-patches-5430dbd95b812d8fa566725885d50ba4024402eb.tar
guix-patches-5430dbd95b812d8fa566725885d50ba4024402eb.tar.gz
gnu: Add freeciv.
* gnu/packages/games.scm (freeciv): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0edd585fa2..98a4d69013 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -104,6 +104,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages tls)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages cyrus-sasl)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -3071,3 +3072,33 @@ symbols, the game needs graphics to render the non-euclidean world.")
for Un*x systems with X11.")
(home-page "http://olofson.net/kobodl/")
(license license:gpl2+)))
+
+(define-public freeciv
+ (package
+ (name "freeciv")
+ (version "2.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.gna.org/freeciv/"
+ "stable/freeciv-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "16wrnsx5rmbz6rjs03bhy0vn20i6n6g73lx7fjpai98ixhzc5bfg"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("gtk+" ,gtk+)
+ ("sdl-mixer" ,sdl-mixer)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.freeciv.org/")
+ (synopsis "Turn based empire building strategy game")
+ (description "Freeciv is a turn based empire building strategy game
+inspired by the history of human civilization. The game commences in
+prehistory and your mission is to lead your tribe from the Stone Age
+to the Space Age.")
+ (license license:gpl2+)))