summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-30 17:30:48 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:33 +0200
commita6dc9f783f9da7beb0d93a761149b36d263ed6ce (patch)
treee0bee20dac5efa4ab3dab3d6bae17ce1a59604ee /gnu
parent556a3ac3aff85d0737d5934f7567af388ae9ecba (diff)
downloadguix-patches-a6dc9f783f9da7beb0d93a761149b36d263ed6ce.tar
guix-patches-a6dc9f783f9da7beb0d93a761149b36d263ed6ce.tar.gz
gnu: hypercorn: Honor #:tests? in 'check' phase.
* gnu/packages/python-web.scm (hypercorn)[arguments]: Honor #:tests? in 'check' phase. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 70f740bc76..608276325f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1650,9 +1650,10 @@ RFC6455, regardless of your programming paradigm.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
;; Propagate because Hypercorn also exposes functionality over a module.
(propagated-inputs
`(("python-h11" ,python-h11)