summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVasile Dumitrascu <va511e@yahoo.com>2018-07-04 18:24:50 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-07 18:10:32 +0200
commita586d1d2bf25742bc21f8e0ebbf9c3b4c138b391 (patch)
tree8ef62d0208690f08bf23d3febc6a28dbea62e0eb /gnu
parent258a28c6494b3b26f0cb0fa7a18ef3c43562391c (diff)
downloadguix-patches-a586d1d2bf25742bc21f8e0ebbf9c3b4c138b391.tar
guix-patches-a586d1d2bf25742bc21f8e0ebbf9c3b4c138b391.tar.gz
gnu: Add emacs-org-brain.
* gnu/packges/emacs.scm (emacs-org-brain): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2bbddc28d3..9f055cfc51 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11291,3 +11291,29 @@ To use, add @code{allow-emacs-pinentry} to @code{~/.gnupg/gpg-agent.conf},
reload the configuration with @code{gpgconf --reload gpg-agent}, and start the
server with @code{M-x pinentry-start}.")
(license license:gpl3+))))
+
+(define-public emacs-org-brain
+ (package
+ (name "emacs-org-brain")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Kungsgeten/org-brain.git")
+ (commit "3faf9303af3f2356e3444e69c22dc6c5774047d1")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ad681zk6kckw2zbk0r4iaj4bw8cfqrbd1s3gdwgdjlzq81q9mmj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Kungsgeten/org-brain")
+ (synopsis "Org-mode wiki and concept-mapping for Emacs")
+ (description "@code{emacs-org-brain} implements a variant of concept
+mapping in Emacs, using @code{org-mode}. An org-brain is a network of
+org-mode entries, where each entry is a file or a headline, and you can get a
+visual overview of the relationships between the entries: parents, children,
+siblings and friends. This visual overview can also be used to browse your
+entries. You can think of entries as nodes in a mind map, or pages in a
+wiki.")
+ (license license:expat)))