summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-27 15:45:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-28 07:56:50 +0200
commit9b416042d162c01b8aa1a8dcac6108847864eb3e (patch)
tree4cc84e9c95a649772583c84ee41febe347a75268 /gnu
parentc75a3081a3baf5a0e26ca0623861ba251286f679 (diff)
downloadguix-patches-9b416042d162c01b8aa1a8dcac6108847864eb3e.tar
guix-patches-9b416042d162c01b8aa1a8dcac6108847864eb3e.tar.gz
gnu: Add texlive-latex-natbib.
* gnu/packages/tex.scm (texlive-latex-natbib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eb69547a1c..819dcd3c3c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1446,6 +1446,29 @@ distribution.")
(description "This is a very limited subset of the TeX Live distribution.
It includes little more than the required set of LaTeX packages.")))
+(define-public texlive-latex-natbib
+ (package
+ (name "texlive-latex-natbib")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "natbib"))
+ (sha256
+ (base32
+ "0aqliq0nwblxyrzhwhv77pnmk7qh2y3prgq7z7qhwcbgz5kisld7"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/natbib"))
+ (home-page "http://www.ctan.org/pkg/natbib")
+ (synopsis "Flexible bibliography support")
+ (description
+ "This bundle provides a package that implements both author-year and
+numbered references, as well as much detailed of support for other
+bibliography use. Also provided are versions of the standard BibTeX styles
+that are compatible with @code{natbib}: @code{plainnat}, @code{unsrtnat},
+@code{abbrnat}. The bibliography styles produced by @code{custom-bib} are
+designed from the start to be compatible with @code{natbib}.")
+ (license license:lppl)))
+
(define texlive-texmf
(package
(name "texlive-texmf")