summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-29 15:03:24 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-04 15:21:47 +0200
commit90fc547fa026e197be45eff8a346a8fd19abe64e (patch)
tree1dd852771f4ef298bcd5d53ac3157b1056215951 /gnu
parentc6f30b81851fde4be31aae7b9d36356c8f72963a (diff)
downloadguix-patches-90fc547fa026e197be45eff8a346a8fd19abe64e.tar
guix-patches-90fc547fa026e197be45eff8a346a8fd19abe64e.tar.gz
gnu: Add python-sympy.
* gnu/packages/python.scm (python-sympy, python2-sympy): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 29b47f357c..98be765853 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3446,6 +3446,32 @@ providing a clean and modern domain specific specification language (DSL) in
Python style, together with a fast and comfortable execution environment.")
(license license:expat)))
+(define-public python-sympy
+ (package
+ (name "python-sympy")
+ (version "0.7.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/sympy/sympy/releases/download/sympy-"
+ version "/sympy-" version ".tar.gz"))
+ (sha256
+ (base32 "19yp0gy4i7p4g6l3b8vaqkj9qj7yqb5kqy0qgbdagpzgkdz958yz"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://www.sympy.org/")
+ (synopsis "Python library for symbolic mathematics")
+ (description
+ "SymPy is a Python library for symbolic mathematics. It aims to become a
+full-featured computer algebra system (CAS) while keeping the code as simple
+as possible in order to be comprehensible and easily extensible.")
+ (license bsd-3)))
+
+(define-public python2-sympy
+ (package-with-python2 python-sympy))
+
(define-public python-testlib
(package
(name "python-testlib")