summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-23 15:23:26 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-04 10:28:26 +0200
commit0a75450c14c7e9639099ec470b037795bb6f8f50 (patch)
tree32841f76067893485b10c49020008f87ce579f2e /gnu
parent167a05aabc229d48d62545ef218d8b0577e6e8f3 (diff)
downloadguix-patches-0a75450c14c7e9639099ec470b037795bb6f8f50.tar
guix-patches-0a75450c14c7e9639099ec470b037795bb6f8f50.tar.gz
gnu: samtools: Remove patch-makefile-curses phase.
* gnu/packages/bioinformatics.scm (samtools)[arguments]: Remove patch-makefile-curses phase, use make-flags instead.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bcb7eba48f..9db8fa4d39 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1068,32 +1068,27 @@ distribution, coverage uniformity, strand specificity, etc.")
;; systems.
#:tests? ,(string=? (or (%current-system) (%current-target-system))
"x86_64-linux")
- #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:make-flags (list "LIBCURSES=-lncurses"
+ (string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(alist-cons-after
'unpack
- 'patch-makefile-curses
- (lambda _
- (substitute* "Makefile"
- (("-lcurses") "-lncurses")))
- (alist-cons-after
- 'unpack
- 'patch-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "test/test.pl"
- ;; The test script calls out to /bin/bash
- (("/bin/bash")
- (string-append bash "/bin/bash"))
- ;; There are two failing tests upstream relating to the "stats"
- ;; subcommand in test_usage_subcommand ("did not have Usage"
- ;; and "usage did not mention samtools stats"), so we disable
- ;; them.
- (("(test_usage_subcommand\\(.*\\);)" cmd)
- (string-append "unless ($subcommand eq 'stats') {" cmd "};")))))
- (alist-delete
- 'configure
- %standard-phases)))))
+ 'patch-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "test/test.pl"
+ ;; The test script calls out to /bin/bash
+ (("/bin/bash")
+ (string-append bash "/bin/bash"))
+ ;; There are two failing tests upstream relating to the "stats"
+ ;; subcommand in test_usage_subcommand ("did not have Usage"
+ ;; and "usage did not mention samtools stats"), so we disable
+ ;; them.
+ (("(test_usage_subcommand\\(.*\\);)" cmd)
+ (string-append "unless ($subcommand eq 'stats') {" cmd "};")))))
+ (alist-delete
+ 'configure
+ %standard-phases))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("ncurses" ,ncurses)
("perl" ,perl)