summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:03:43 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:12 +0300
commitc1b9d72ca1e0922eb67f943c2f3521cde3251482 (patch)
treef636cde52144ccb2fedbbb4c49c96808db1257a0 /gnu
parent8aab3d06115671e120291354ccdc4775dd325786 (diff)
downloadguix-patches-c1b9d72ca1e0922eb67f943c2f3521cde3251482.tar
guix-patches-c1b9d72ca1e0922eb67f943c2f3521cde3251482.tar.gz
gnu: Add emacs-helm-shell-history.
* gnu/packages/emacs.scm (emacs-helm-shell-history): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2648f1f70c..3a3bbb4ff7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9064,3 +9064,36 @@ documentation.")
(description "This package provides an Emacs functions to format HTML,
CSS, JavaScript, JSON.")
(license license:gpl3+)))
+
+(define-public emacs-helm-shell-history
+ (let ((commit "110d3c35c52fe4b89b29e79ea4c8626bce7266a1"))
+ (package
+ (name "emacs-helm-shell-history")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yuutayamada/helm-shell-history.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18fkjcz69g4dyaxhf9j8svr5x6dhsdnglddwisis8hdn504scpfj"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-helm-shell-history-file
+ (lambda _
+ (let ((file "helm-shell-history.el"))
+ (chmod file #o644)
+ (emacs-substitute-sexps file
+ ("(defvar helm-shell-history-file"
+ `(expand-file-name "~/.bash_history"))))
+ #t)))))
+ (home-page "https://github.com/yuutayamada/helm-shell-history")
+ (synopsis "Find shell history with Emacs Helm")
+ (description "This package provides an Emacs Helm interface to search
+throw a shell history.")
+ (license license:gpl3+))))