summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:09:55 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:16 +0300
commitbf8300de402d231d70a26a2f70bab72fb72108b0 (patch)
tree3a9ecbc92e8b018569dbca287ece2cc7170d2135 /gnu
parent6e28f15c5866b21c7db97f2d6662449c1030c635 (diff)
downloadguix-patches-bf8300de402d231d70a26a2f70bab72fb72108b0.tar
guix-patches-bf8300de402d231d70a26a2f70bab72fb72108b0.tar.gz
gnu: Add emacs-rsw-elisp.
* gnu/packages/emacs.scm (emacs-rsw-elisp): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1bc1622ea0..9f9c479f4a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9664,3 +9664,25 @@ split to display more windows and more buffers, the buffer exits
@code{darkroom-mode}. Whenever they are deleted, the buffer re-enters
@code{darkroom-mode}.")
(license license:gpl3+)))
+
+(define-public emacs-rsw-elisp
+ (package
+ (name "emacs-rsw-elisp")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rswgnu/rsw-elisp"
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jnn7xfwl3wxc87v44ccsf1wwp80par3xgcvfb1icd6zchjmlcps"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rswgnu/rsw-elisp")
+ (synopsis "Improved expressions that interactively evaluate Emacs Lisp")
+ (description "This package improves and replaces the GNU Emacs commands
+that interactively evaluate Emacs Lisp expressions. The new commands replace
+standard key bindings and are all prefixed with rsw-elisp-. They work the
+same way as the old commands when called non-interactively; only the
+interactive behavior should be different.")
+ (license license:gpl3+)))