summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:02:31 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:11 +0300
commitb8ddef4b134ee19bd1fbbeb81c26cdef36d328fa (patch)
tree054575a9f9c2e3733665d343d3deabafb6658fe8 /gnu
parent045f6b7c13ed9b13ec1e895e6cd41b593ed32a5a (diff)
downloadguix-patches-b8ddef4b134ee19bd1fbbeb81c26cdef36d328fa.tar
guix-patches-b8ddef4b134ee19bd1fbbeb81c26cdef36d328fa.tar.gz
gnu: Add emacs-company-lua.
* gnu/packages/emacs.scm (emacs-company-lua): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 36f9aa166e..c5b43c86b5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8889,3 +8889,30 @@ until the top-level form is no longer a macro call.")
(synopsis "Execute menu items as commands, with completion")
(description "Execute menu items as commands, with completion.")
(license license:gpl3)))
+
+(define-public emacs-company-lua
+ (let ((commit "0be8122f3adf57ad27953bf4b03545d6298d3da4"))
+ (package
+ (name "emacs-company-lua")
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ptrv/company-lua.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d9i165apgmwns7b2fd5wcpjpkah3dyj20v5sb8ynvz6qhhr5r9c"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-s" ,emacs-s)
+ ("emacs-f" ,emacs-f)
+ ("emacs-lua-mode" ,emacs-lua-mode)))
+ (home-page "https://github.com/ptrv/company-lua")
+ (synopsis "Company backend for Lua")
+ (description
+ "This package provides Company backend for Lua programming language.")
+ (license license:gpl3+))))