summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:04:38 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:13 +0300
commit9b876c69168e67c73aec5ee39a4b32cbafc0558c (patch)
treeef82df25d130d99132dbe67d18974d140e14418a /gnu
parent58b50580cf2e29e98721200cad4fee60fbe60f43 (diff)
downloadguix-patches-9b876c69168e67c73aec5ee39a4b32cbafc0558c.tar
guix-patches-9b876c69168e67c73aec5ee39a4b32cbafc0558c.tar.gz
gnu: Add emacs-know-your-http-well.
* gnu/packages/emacs.scm (emacs-know-your-http-well): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1eea888e19..4d7c3e5367 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9204,3 +9204,38 @@ feeling, where the region stays static (instead of being brutally moved to a
blank slate) and is clearly highlighted with respect to the rest of the
buffer.")
(license license:gpl2+)))
+
+(define-public emacs-know-your-http-well
+ (package
+ (name "emacs-know-your-http-well")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/for-GET/know-your-http-well/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1y3kwz88awcgwaivlswq0q4g2i02762r23lpwg61bfqy5lrjjqnj"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'install-json-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each (lambda (directory)
+ (copy-recursively directory
+ (string-append
+ (assoc-ref outputs "out")
+ directory)))
+ '("js" "json"))))
+ (add-after 'unpack 'chdir-elisp
+ ;; Elisp directory is not in root of the source.
+ (lambda _
+ (chdir "emacs"))))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/for-GET/know-your-http-well")
+ (synopsis "Meaning of HTTP headers codes")
+ (description "Meaning of HTTP headers codes.")
+ (license license:gpl3+)))