summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:08:01 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:15 +0300
commit6d6d9acc53d29eb5558c8a503f773dd883cad96d (patch)
tree3e65cf778d6384c90aa72172d0eada550029f52e /gnu
parent89378bb87b5f8cb68fb51a9c19b8fbdc372c65fe (diff)
downloadguix-patches-6d6d9acc53d29eb5558c8a503f773dd883cad96d.tar
guix-patches-6d6d9acc53d29eb5558c8a503f773dd883cad96d.tar.gz
gnu: Add emacs-lice-el.
* gnu/packages/emacs.scm (emacs-lice-el): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 77b5d2c9ca..9ea2c493fe 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9518,3 +9518,28 @@ with absolutely no stored indexes (TAGS) or persistent background processes.
Dumb Jump performs best with The Silver Searcher `ag` or ripgrep `rg`
installed. Dumb Jump requires at least GNU Emacs 24.3. ")
(license license:gpl3+)))
+
+(define-public emacs-lice-el
+ (let ((commit "4339929927c62bd636f89bb39ea999d18d269250"))
+ (package
+ (name "emacs-lice-el")
+ (version (git-version "0.2" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/buzztaiki/lice-el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0879z761b7gajkhq176ps745xpdrivch349crransv8fnsc759yb"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/buzztaiki/lice-el")
+ (synopsis "License and header template for Emacs")
+ (description "@code{lice.el} provides following features:
+
+@itemize
+@item License template management.
+@item File header insertion.
+@end itemize\n")
+ (license license:gpl3+))))