summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:02:54 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:12 +0300
commit666e5617234bf7609321be168f600a0637e8599b (patch)
treececbabed830e0b594bf59e9d43301f79f203c860 /gnu
parentf61ecb8546299049567b885c8d87f77fe2c0fde8 (diff)
downloadguix-patches-666e5617234bf7609321be168f600a0637e8599b.tar
guix-patches-666e5617234bf7609321be168f600a0637e8599b.tar.gz
gnu: Add emacs-mbsync.
* gnu/packages/emacs.scm (emacs-mbsync): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index bde1bd01e4..b0331d9d0e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8941,3 +8941,27 @@ keybindings for Emacs modes so that point moves to meaningful
locations. Redefined keys are still accessible by pressing the same
key again.")
(license license:gpl3+)))
+
+(define-public emacs-mbsync
+ (let ((commit "42077e83ae2db778ce0f8e22f8357b40355526b3")
+ (revision "1"))
+ (package
+ (name "emacs-mbsync")
+ (version (string-append "0.0.1" "-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dimitri/mbsync-el.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0yj93y2mpxlir8x73znlg1slxlv4blm1vjv5h2w3j8lxg8bxvmn6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dimitri/mbsync-el")
+ (synopsis "Interface to mbsync for Emacs")
+ (description "This package allows to call the @code{mbsync} from
+within Emacs.")
+ (license license:gpl3+))))