summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:13:46 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:18 +0300
commit47667501f5e7b1b47e1e6764fa02014c2d9e3fc1 (patch)
tree9c0b36181e28f273dce1ad74c2c7f8d9e797dcd2 /gnu
parentca0e2ab00a2cce29a1814e5aeebdeae8f09af59f (diff)
downloadguix-patches-47667501f5e7b1b47e1e6764fa02014c2d9e3fc1.tar
guix-patches-47667501f5e7b1b47e1e6764fa02014c2d9e3fc1.tar.gz
gnu: Add emacs-on-screen.
* gnu/packages/emacs.scm (emacs-on-screen): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fdcd769052..77a4f153a2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10031,3 +10031,26 @@ bookmarks and history.")
(description "This package provides functions to generate random words
using user-provided rules.")
(license license:gpl3+)))
+
+(define-public emacs-on-screen
+ (package
+ (name "emacs-on-screen")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://elpa.gnu.org/packages/on-screen-" version ".el"))
+ (file-name (string-append name "-" version ".el"))
+ (sha256
+ (base32
+ "15d18mjgv1pnwl6kf3pr5w64q1322p1l1qlfvnckglwmzy5sl2qv"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/michael-heerdegen/on-screen.el")
+ (synopsis "Guide your eyes while scrolling")
+ (description
+ "Scrolling can be distracting because your eyes may lose
+orientation. This library implements a minor mode that highlights
+the previously visible buffer part after each scroll.")
+ (license license:gpl3+)))