summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:03:20 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:12 +0300
commit295513c618edcbab888da67057bcd629bb74c630 (patch)
tree4b2444ec1a7ff96e6910cdba241697f31b6dbe20 /gnu
parent60bf926534e813d631f02e0c02ef81052eeeba0d (diff)
downloadguix-patches-295513c618edcbab888da67057bcd629bb74c630.tar
guix-patches-295513c618edcbab888da67057bcd629bb74c630.tar.gz
gnu: Add emacs-helm-mode-manager.
* gnu/packages/emacs.scm (emacs-helm-mode-manager): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index bae01844bf..1419b99092 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8991,3 +8991,34 @@ within Emacs.")
(description "Adds functionality to Emacs @code{ibuffer} for
grouping buffers by their projectile root directory.")
(license license:gpl3+))))
+
+(define-public emacs-helm-mode-manager
+ (package
+ (name "emacs-helm-mode-manager")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/istib/helm-mode-manager/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wllj321z16hgrx0ddwzk5wz4mnnx5am7w5nclqclfc5dfdn92wm"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/istib/helm-mode-manager/")
+ (synopsis "Switch and toggle Emacs major and minor modes using Helm")
+ (description "This package provides a Helm interface for toggling Emacs
+major or minor mode.
+
+@itemize
+@item @code{helm-switch-major-mode} list of all major modes
+@item @code{helm-enable-minor-mode} list of all inactive minor modes
+@item @code{helm-disable-minor-mode} list of all ACTIVE minor modes
+@end itemize\n
+
+Hitting @code{RET} enables the mode, @code{C-z} shows the mode
+documentation.")
+ (license license:gpl3+)))