summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-20 00:32:16 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-20 00:32:16 +0200
commit7c80a8b618274177c6ca0a8eecfd86a3a50b051a (patch)
treec92517a81b2c16597c9c7790ef9c3d0a0e311ac8 /gnu
parent0f323dad0e7e2bf259003a956140d4d0cb4fc0e5 (diff)
downloadguix-patches-7c80a8b618274177c6ca0a8eecfd86a3a50b051a.tar
guix-patches-7c80a8b618274177c6ca0a8eecfd86a3a50b051a.tar.gz
gnu: ddrescue: Update to 1.17.
* gnu/packages/ddrescue.scm (ddrescue): Update to 1.17. Add lzip as a native input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ddrescue.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ddrescue.scm b/gnu/packages/ddrescue.scm
index 5c653af6db..f990199a62 100644
--- a/gnu/packages/ddrescue.scm
+++ b/gnu/packages/ddrescue.scm
@@ -20,24 +20,25 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module ((gnu packages compression) #:select (lzip)))
(define-public ddrescue
(package
(name "ddrescue")
- (version "1.16")
+ (version "1.17")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/ddrescue/ddrescue-"
- version ".tar.gz"))
+ version ".tar.lz"))
(sha256
(base32
- "1rixya7p8c4jrn4p0flf6h5dqwybrilf3hrj4r7x41h3zgjz5cvn"))))
+ "0bvmsbzli2j4czwkabzs978n1y6vx31axh02kpgcf7033cc6rydy"))))
(build-system gnu-build-system)
- (home-page
- "http://www.gnu.org/software/ddrescue/ddrescue.html")
+ (home-page "http://www.gnu.org/software/ddrescue/ddrescue.html")
(synopsis "Data recovery utility")
+ (native-inputs `(("lzip" ,lzip)))
(description
"GNU Ddrescue is a data recovery tool. It copies data from one
file or block device (e.g., hard disk, CD-ROM) to another, trying hard to