summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:27:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:08 +0200
commitd3abd5cd8b16a9a4121da08a2778dd8a3b9cbae6 (patch)
tree141ef4a824c70805d79d6b64de7963c9677b3762 /gnu
parentea173bd87414f72ce61c0436b9503bef7f1beb45 (diff)
downloadguix-patches-d3abd5cd8b16a9a4121da08a2778dd8a3b9cbae6.tar
guix-patches-d3abd5cd8b16a9a4121da08a2778dd8a3b9cbae6.tar.gz
gnu: simgear: Remove bundled expat.
* gnu/packages/games.scm (simgear)[source]: Add snippet to remove bundled expat. [arguments]: Add configure-flag to use system expat.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1ea1846c0a..df32a6b27d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9269,10 +9269,18 @@ levels to unlock.")
(version-major+minor version) "/"
"simgear-" version ".tar.bz2"))
(sha256
- (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))))
+ (base32 "0g2g3n3sb6kdimvcrn9kvlhyyrp5c6lx20fgzz8l609v5aygr3dv"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; There are some bundled libraries.
+ (for-each delete-file-recursively
+ '("3rdparty/expat/"))
+ #t))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags (list "-DSYSTEM_EXPAT=ON")
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)