summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 17:41:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 17:41:43 +0100
commitb9a30e0d37525e714a232318c26c7e4ef8250dc1 (patch)
tree24f4a76ad697f2be046185a4b84e4b7dc512a767 /gnu
parent0e5f3282601f84b7dfba65cbc617c31629040223 (diff)
downloadguix-patches-b9a30e0d37525e714a232318c26c7e4ef8250dc1.tar
guix-patches-b9a30e0d37525e714a232318c26c7e4ef8250dc1.tar.gz
gnu: efibootmgr: Fix build failure with GCC7.
* gnu/packages/linux.scm (efibootmgr)[arguments]: Set C_INCLUDE_PATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ed092e1c73..6049b09139 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4142,7 +4142,12 @@ interface to the variable facility of UEFI boot firmware.")
;; installed (known as OS_VENDOR in the code).
;; GRUB overrides this, as such it's only used if
;; nothing else is specified on the command line.
- "EFIDIR=gnu")
+ "EFIDIR=gnu"
+ ;; Treat kernel headers as system headers to prevent
+ ;; warnings about conflicting types.
+ (string-append "C_INCLUDE_PATH="
+ (assoc-ref %build-inputs "kernel-headers")
+ "/include"))
#:phases (modify-phases %standard-phases (delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))