summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-14 00:13:30 +0100
committerMarius Bakke <marius@gnu.org>2021-12-14 00:14:15 +0100
commitbdcfe80b41e3d973591272036461c263d3713b22 (patch)
tree7d29255b2b59dd461bbbd9c090c04f9fb8471be6 /gnu
parent6601cc78bb728f19cb181b1bd3f78cccce23ec4b (diff)
downloadguix-patches-bdcfe80b41e3d973591272036461c263d3713b22.tar
guix-patches-bdcfe80b41e3d973591272036461c263d3713b22.tar.gz
gnu: python-setuptools-scm-git-archive: Don't install duplicate egginfo.
* gnu/packages/python-xyz.scm (python-setuptools-scm-git-archive)[arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4903b8538..270d665251 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19786,6 +19786,16 @@ services.")
(base32
"1nii1sz5jq75ilf18bjnr11l9rz1lvdmyk66bxl7q90qan85yhjj"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'dont-install-defunct-egginfo
+ (lambda _
+ ;; When a ".git" directory is missing, the setup.py
+ ;; script invokes setuptools.setup twice, once with
+ ;; "0" as the version. Prevent that.
+ (substitute* "setup.py"
+ (("if not isdir\\('\\.git'\\):")
+ "if False:")))))))
(native-inputs
(list python-pytest))
(propagated-inputs