summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 01:59:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 04:58:34 +0200
commit1c17a61bdc388b6c842a52f0ae7e5656867f51aa (patch)
treefacfed63ac9fa33955d49dfd0f7e89e90b2f8c05 /gnu
parent5cea72818db253c3cb7bc688d8d04d72d7b78777 (diff)
downloadguix-patches-1c17a61bdc388b6c842a52f0ae7e5656867f51aa.tar
guix-patches-1c17a61bdc388b6c842a52f0ae7e5656867f51aa.tar.gz
gnu: phodav: Update to 2.5.
* gnu/packages/gnome.scm (phodav): Update to 2.5. [arguments]: Work around a test failure. [native-inputs]: Add docbook-xml-4.3.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bfe1ca43c2..8e2ba91d61 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1029,7 +1029,7 @@ Library reference documentation.")
(define-public phodav
(package
(name "phodav")
- (version "2.4")
+ (version "2.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1037,10 +1037,21 @@ Library reference documentation.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1hxq8c5qfah3w7mxcyy3yhzdgswplll31a69p5mqdl04bsvw5pbx"))))
+ "045rdzf8isqmzix12lkz6z073b5qvcqq6ad028advm5gf36skw3i"))))
(build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-virtual-dir-server
+ ;; The same server when started by tests/virtual-dir returns an
+ ;; unexpected status (4 instead of 200) and fails a test. It is
+ ;; unclear why starting it manually here makes it pass.
+ (lambda _
+ (system "tests/virtual-dir-server &")
+ #t)))))
(native-inputs
- `(("gettext" ,gettext-minimal)
+ `(("docbook-xml" ,docbook-xml-4.3)
+ ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)))