summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-11-05 12:27:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-06 19:53:14 +0000
commit462bf27157d43a58e850dd596e3af169da152be1 (patch)
tree86327f3854cc573deb3ee8fe611f9575c1de9c4f /gnu
parent9dede065ba950760b91300c4cdde46ef13a0242b (diff)
downloadguix-patches-462bf27157d43a58e850dd596e3af169da152be1.tar
guix-patches-462bf27157d43a58e850dd596e3af169da152be1.tar.gz
gnu: Add python-flask-babel.
* gnu/packages/python.scm (python-flask-babel, python2-flask-babel): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1f7a2c0bce..25ca9674c1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3956,6 +3956,39 @@ multivalue dictionary that retains the order of insertions and deletions.")
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+(define-public python-flask-babel
+ (package
+ (name "python-flask-babel")
+ (version "0.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Babel" version))
+ (sha256
+ (base32
+ "16b80cipdba9xj3jlaiaq6wgrgpjb70w3j01jjy9hbp4k71kd6yj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-babel" ,python-babel)
+ ("python-jinja2" ,python-jinja2)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/python-babel/flask-babel")
+ (synopsis "Add i18n/l10n support to Flask applications")
+ (description "This package implements internationalization and localization
+support for Flask. This is based on the Python babel module as well as pytz -
+both of which are installed automatically if you install this library.")
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-flask-babel))))))
+
+(define-public python2-flask-babel
+ (let ((base (package-with-python2 (strip-python2-variant
+ python-flask-babel))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
+
(define-public python-sqlalchemy-utils
(package
(name "python-sqlalchemy-utils")