summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2016-10-20 15:45:04 +0530
committerLeo Famulari <leo@famulari.name>2016-11-05 16:32:19 -0400
commit06ff0837548899fb5a5ee2ce29396db45f5925a1 (patch)
tree7ab773e4e09e36b0587c40a7c83f898b81847f7c /gnu
parent2f6dd9cdef58c01668f89e046b182b8235f9c556 (diff)
downloadguix-patches-06ff0837548899fb5a5ee2ce29396db45f5925a1.tar
guix-patches-06ff0837548899fb5a5ee2ce29396db45f5925a1.tar.gz
gnu: Add python-axolotl.
* gnu/packages/python.scm (python-axolotl, python2-axolotl): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b656a1e32b..5c26906bda 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages statistics)
@@ -11943,3 +11944,46 @@ python-axolotl.")
(define-public python2-axolotl-curve25519
(package-with-python2 python-axolotl-curve25519))
+
+(define-public python-axolotl
+ (package
+ (name "python-axolotl")
+ (version "0.1.35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tgalal/python-axolotl/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1z8d89p7v40p4bwywjm9h4z28fdvra79ddw06azlkrfjbl7dxmz8"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Don't install tests
+ (add-before 'install 'remove-tests
+ (lambda _
+ (for-each delete-file-recursively
+ '("axolotl/tests" "build/lib/axolotl/tests"))
+ #t)))
+ ;; Prevent creation of the egg. This works around
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765
+ #:configure-flags '("--root=/")))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (propagated-inputs
+ `(("python-axolotl-curve25519" ,python-axolotl-curve25519)
+ ("python-dateutil" ,python-dateutil)
+ ("python-protobuf" ,python-protobuf)
+ ("python-pycrypto" ,python-pycrypto)))
+ (home-page "https://github.com/tgalal/python-axolotl")
+ (synopsis "Python port of libaxolotl-android")
+ (description "This is a python port of libaxolotl-android. This
+is a ratcheting forward secrecy protocol that works in synchronous and
+asynchronous messaging environments.")
+ (license license:gpl3)))
+
+(define-public python2-axolotl
+ (package-with-python2 python-axolotl))