summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDomagoj Stolfa <domagoj.stolfa@gmail.com>2021-07-11 15:55:54 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:14:16 +0300
commitc52cba9847023fb3e37a3a149dff1a91a5b6e881 (patch)
treef982003d02b3b8388d53d72ee662348e2bf2806d /gnu
parent5b5332816818acbf0a1e50e5a6fc3c6c002b46b0 (diff)
downloadguix-patches-c52cba9847023fb3e37a3a149dff1a91a5b6e881.tar
guix-patches-c52cba9847023fb3e37a3a149dff1a91a5b6e881.tar.gz
gnu: Add rust-postgres-0.19.
* gnu/packages/crates-io.scm (rust-postgres-0.19): New variable. (rust-postgres-0.15): Inherit from rust-postgres-0.19. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 34 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 31d0c5ab8b..a8e1d20985 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32832,8 +32832,41 @@ overloading without macros in Rust.")
UDP.")
(license license:unlicense)))
+(define-public rust-postgres-0.19
+ (package
+ (name "rust-postgres")
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hnid1d78zrr8ph12lpvp5b2cpx2fsqqgqs2yn1q23c6g7jix1y7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:rust ,rust-1.46 ; or later
+ #:tests? #f ; tests require postgres server.
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-1)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-postgres" ,rust-tokio-postgres-0.7))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Native, synchronous PostgreSQL client")
+ (description
+ "This package provides a native, synchronous PostgreSQL client.")
+ (license license:expat)))
+
(define-public rust-postgres-0.15
(package
+ (inherit rust-postgres-0.19)
(name "rust-postgres")
(version "0.15.2")
(source
@@ -32857,12 +32890,7 @@ UDP.")
("rust-rustc-serialize" ,rust-rustc-serialize-0.3)
("rust-schannel" ,rust-schannel-0.1)
("rust-security-framework" ,rust-security-framework-0.1)
- ("rust-socket2" ,rust-socket2-0.3))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Native, synchronous PostgreSQL client")
- (description
- "This package provides a native, synchronous PostgreSQL client.")
- (license license:expat)))
+ ("rust-socket2" ,rust-socket2-0.3))))))
(define-public rust-postgres-derive-0.4
(package