summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDomagoj Stolfa <domagoj.stolfa@gmail.com>2021-07-11 15:55:47 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:14:15 +0300
commit63fab9e16ce7b1b566d72bf30191543ab8c5a05a (patch)
tree8b2af03079286b10532d8afa542ccaff3d43c59a /gnu
parent39a31ec44321c05cf4c2cfc025782a18c598294e (diff)
downloadguix-patches-63fab9e16ce7b1b566d72bf30191543ab8c5a05a.tar
guix-patches-63fab9e16ce7b1b566d72bf30191543ab8c5a05a.tar.gz
gnu: Add rust-postgres-protocol-0.6.
* gnu/packages/crates-io.scm (rust-postgres-protocol-0.6): New variable. (rust-postgres-protocol-0.3): Inherit from rust-postgres-protocol-0.6. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm41
1 files changed, 34 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0d4a107347..868a85da66 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32865,8 +32865,41 @@ UDP.")
"This is an internal crate used by postgres-types.")
(license (list license:expat license:asl2.0))))
+(define-public rust-postgres-protocol-0.6
+ (package
+ (name "rust-postgres-protocol")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres-protocol" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-base64" ,rust-base64-0.13)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
+ ("rust-hmac" ,rust-hmac-0.10)
+ ("rust-md-5" ,rust-md-5-0.9)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-stringprep" ,rust-stringprep-0.1))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Low level Postgres protocol APIs")
+ (description
+ "This package provides low level Postgres protocol APIs.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-postgres-protocol-0.3
(package
+ (inherit rust-postgres-protocol-0.6)
(name "rust-postgres-protocol")
(version "0.3.2")
(source
@@ -32876,7 +32909,6 @@ UDP.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "04kkznbhwspfn0hdja3jsv37l6g5gz7a625z8yra325zamjfd1r4"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -32890,12 +32922,7 @@ UDP.")
("rust-memchr" ,rust-memchr-1)
("rust-rand" ,rust-rand-0.3)
("rust-sha2" ,rust-sha2-0.7)
- ("rust-stringprep" ,rust-stringprep-0.1))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Low level Postgres protocol APIs")
- (description
- "This package provides low level Postgres protocol APIs.")
- (license (list license:expat license:asl2.0))))
+ ("rust-stringprep" ,rust-stringprep-0.1))))))
(define-public rust-postgres-shared-0.4
(package