summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-13 10:19:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-13 11:22:33 -0400
commit139ad8be2c97b2974f23022a1cd11d04e98af16c (patch)
tree8a4be7b96a7f2a8c8fdfc084a9c414c00442a4ad /gnu
parent08935e5fff2ad9b453aced96f3c7453004945175 (diff)
downloadguix-patches-139ad8be2c97b2974f23022a1cd11d04e98af16c.tar
guix-patches-139ad8be2c97b2974f23022a1cd11d04e98af16c.tar.gz
gnu: Add python-wsgiprox.
* gnu/packages/python-web.scm (python-wsgiprox): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8ec6864b8b..4645e2230b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5303,6 +5303,46 @@ Plus all the standard features of requests:
@end itemize")
(license license:bsd-3)))
+(define-public python-wsgiprox
+ (package
+ (name "python-wsgiprox")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wsgiprox" version))
+ (sha256
+ (base32
+ "11fsm199pvwbmqx2lccznvws65aam1rqqv0w79gal8hispwgd5rs"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The test suite hangs (see:
+ ;; https://github.com/webrecorder/wsgiprox/issues/6).
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-argument
+ (lambda _
+ ;; See: https://github.com/webrecorder/wsgiprox/issues/7.
+ (substitute* "setup.py"
+ (("--doctest-module")
+ "--doctest-modules")))))))
+ (propagated-inputs
+ `(("python-certauth" ,python-certauth)
+ ("python-gevent" ,python-gevent)
+ ("python-websocket-client" ,python-websocket-client)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-waitress" ,python-waitress)))
+ (home-page "https://github.com/webrecorder/wsgiprox")
+ (synopsis "HTTP/S proxy with WebSockets over WSGI")
+ (description "@code{wsgiprox} is a Python WSGI (Web Server Gateway
+Interface) middle-ware for adding HTTP and HTTPS proxy support to a WSGI
+application. The library accepts HTTP and HTTPS proxy connections, and routes
+them to a designated prefix.")
+ (license license:asl2.0)))
+
(define-public python-websockets
(package
(name "python-websockets")