summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-14 18:42:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-14 18:42:41 +0200
commiteb3362cc8dacb5ef5e5f6c72522898cf30e1541a (patch)
tree702398987da4e9eff68af0800a2601b43f20f887 /gnu
parentbeb418bbf47e9faa6bdfa4af1e582fcb87c55e0d (diff)
downloadguix-patches-eb3362cc8dacb5ef5e5f6c72522898cf30e1541a.tar
guix-patches-eb3362cc8dacb5ef5e5f6c72522898cf30e1541a.tar.gz
gnu: zlib: Update to 1.2.13.
* gnu/packages/compression.scm (zlib): Update to 1.2.13. [source]: Remove patches. * gnu/packages/patches/zlib-cc.patch, gnu/packages/patches/zlib-correct-crc32-inputs.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/compression.scm6
-rw-r--r--gnu/packages/patches/zlib-cc.patch21
-rw-r--r--gnu/packages/patches/zlib-correct-crc32-inputs.patch44
4 files changed, 2 insertions, 71 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bc8a1f2a07..8821c3fd8b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1999,8 +1999,6 @@ dist_patch_DATA = \
%D%/packages/patches/xterm-370-explicit-xcursor.patch \
%D%/packages/patches/xygrib-fix-finding-data.patch \
%D%/packages/patches/yggdrasil-extra-config.patch \
- %D%/packages/patches/zlib-cc.patch \
- %D%/packages/patches/zlib-correct-crc32-inputs.patch \
%D%/packages/patches/zig-use-system-paths.patch
MISC_DISTRO_FILES = \
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 501db8f38b..a1f8d0389c 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -100,7 +100,7 @@
(define-public zlib
(package
(name "zlib")
- (version "1.2.12")
+ (version "1.2.13")
(source
(origin
(method url-fetch)
@@ -108,11 +108,9 @@
version ".tar.gz")
(string-append "mirror://sourceforge/libpng/zlib/"
version "/zlib-" version ".tar.gz")))
- (patches (search-patches "zlib-cc.patch"
- "zlib-correct-crc32-inputs.patch"))
(sha256
(base32
- "1n9na4fq4wagw1nzsfjr6wyly960jfa94460ncbf6p1fac44i14i"))))
+ "0c5b8vw40dy178xlpddw65q9gf1h2186jcc3p4swinwggbllv8mk"))))
(build-system gnu-build-system)
(outputs '("out" "static"))
(arguments
diff --git a/gnu/packages/patches/zlib-cc.patch b/gnu/packages/patches/zlib-cc.patch
deleted file mode 100644
index 6b9666f5b4..0000000000
--- a/gnu/packages/patches/zlib-cc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix configure issue that discarded provided CC definition.
-
-Taken from upstream:
-
- https://github.com/madler/zlib/commit/05796d3d8d5546cf1b4dfe2cd72ab746afae505d
-
-diff --git a/configure b/configure
-index 52ff4a04e..3fa3e8618 100755
---- a/configure
-+++ b/configure
-@@ -174,7 +174,10 @@ if test -z "$CC"; then
- else
- cc=${CROSS_PREFIX}cc
- fi
-+else
-+ cc=${CC}
- fi
-+
- cflags=${CFLAGS-"-O3"}
- # to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
- case "$cc" in
diff --git a/gnu/packages/patches/zlib-correct-crc32-inputs.patch b/gnu/packages/patches/zlib-correct-crc32-inputs.patch
deleted file mode 100644
index 8b09436e2b..0000000000
--- a/gnu/packages/patches/zlib-correct-crc32-inputs.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Correct incorrect inputs provided to the CRC functions.
-
-Taken from upstream:
-
- https://github.com/madler/zlib/commit/ec3df00224d4b396e2ac6586ab5d25f673caa4c2
-
-diff --git a/crc32.c b/crc32.c
-index a1bdce5c2..451887bc7 100644
---- a/crc32.c
-+++ b/crc32.c
-@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
-
- /* Pre-condition the CRC */
-- crc ^= 0xffffffff;
-+ crc = (~crc) & 0xffffffff;
-
- /* Compute the CRC up to a word boundary. */
- while (len && ((z_size_t)buf & 7) != 0) {
-@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
-
- /* Pre-condition the CRC */
-- crc ^= 0xffffffff;
-+ crc = (~crc) & 0xffffffff;
-
- #ifdef W
-
-@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
- #ifdef DYNAMIC_CRC_TABLE
- once(&made, make_crc_table);
- #endif /* DYNAMIC_CRC_TABLE */
-- return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
-+ return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
- }
-
- /* ========================================================================= */
-@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
- uLong crc2;
- uLong op;
- {
-- return multmodp(op, crc1) ^ crc2;
-+ return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
- }